Dev:JA/Ref/Release Notes/2.93/Core

提供: wiki
移動先: 案内検索

■2021/06/02(水) 9:11

元記事:Reference/Release Notes/2.93/Core - Blender Developer Wiki

Library Overrides(ライブラリオーバーライド)

再同期プロセスの改善

ライブラリオーバーライドの再同期は、ソースリンクデータと、そのデータブロックとの間の関係に変更があった時に必要になります。

このプロセスが簡単になり、その大半が完全に自動になりました。

  • 新しく作成したファイルやオーバーライドでは、.blend ファイル読み込み時、再同期が必要かどうかを探知し、自動的に実行します。
  • ただし、一部のケース、特に '壊れた'(階層が合わない)オーバーライドとともに保存された古いファイルでは、再同期自体が期待通りに正しくオーバーライドを再構築できません(オブジェクトの一部が消えるなど)。
    このようなケースのために、アウトライナーの右クリックメニューに新しいオペレーター、Resync Library Override Hierarchy Enforce(ライブラリオーバーライド階層を強制再同期) を追加しました。これは ID ポインタープロパティの一部のオーバーライドを失う可能性と引き換えに、基本的にもっとアグレッシブな再同期を行います。
  • プリファレンスの Experimental(実験的) エリア内に、この読み込み時の自動再同期機能を無効化するオプションが追加されました。一部の複雑な制作ファイルでは、先に適切な手動による処理を行う必要があると思われるためです。
注意
この新しい Resync Library Override Hierarchy Enforce(ライブラリオーバーライド階層を強制再同期)オペレーターは、オーバーライド情報の一部を失う可能性があるものの、代わりの ResetResync プロセスに比べ、切断は大幅に減ります。


自動再同期の探知とデータブロックの維持は、このオーバーライドによりもはや不要となりましたが、以前ユーザーにより編集されたデータブロックと、オブジェクトやコレクションは、専用のコレクション、OVERRIDE_RESYNC_LEFTOVERS に置かれます。

アウトライナーの新しいオーバーライドビュー

現在のライブラリオーバーライドの基本的な情報を表示するビューをアウトライナーに追加。(rBe1ae5bd45fd0).

Outliner の Override ビュー

システムが生成したオーバーライド(オーバライド階層を確保するための、他のオーバーライドデータブロックへのポインタのオーバーライドなど)はデフォルトで非表示になっており、フィルターオプションで表示可能です。

(自動)再同期プロセスからの潜在的な情報や警告メッセージも、影響のあるアイテムの横にアイコン+ツールチップで表示されます。

Blenloader

  • 未圧縮の .blend ファイル読み込みをスピードアップすべく、メモリマップド I/O の使用に対応。(rB0f2ae614a17a)

データ管理

  • 未使用データブロックを削除する Purge(パージ)オペレーターを改良、リンク中またはローカルデータのみ処理できるようになり、「間接的な」すべての未使用データブロックを、一度で再帰的に削除可能です(rB2718ea80d262 と関連コミット)。現在、新しい挙動は File -> Clean Up(ファイル→クリーンアップ) からのみアクセス可能です。

リンクデータ

  • 壊れたライブラリのある .blend ファイル読み込み時、行方不明のライブラリとリンクデータブロックが UI 内の単一の警告として報告されるように。完全な情報はコンソールまたは Info(情報)エディターにあります。(rB53d13b6f5387c68)