Doc:JA/2.6/Manual/Animation/Editors/DopeSheet

提供: wiki
< Doc:JA‎ | 2.6‎ | Manual‎ | Animation‎ | Editors
2018年6月29日 (金) 06:08時点におけるYamyam (トーク | 投稿記録)による版 (1版 をインポートしました)
(差分) ← 古い版 | 最新版 (差分) | 新しい版 → (差分)
移動先: 案内、 検索


Page status (reviewing guidelines)

Partial page
Proposed fixes: none

The Dopesheet

(ドープシート)

The DopeSheet

古くは手描きのアニメーターはよく、絵や音、カメラがいつ、どれだけ動くのか、正確に示す表を作りました。この表のニックネームは「ドープシート(競馬予想紙)」でした。CGの根本は手描きのアニメーションと大きく違いますが、Blender のドープシートは類似した指示書を受け継いでいます。アニメーターはシーン内で起きるすべてのことを「鳥瞰図」のように見ることができます。


Dope Sheet Modes

(ドープシートのモード)

DopeSheet modes

ドープシートには4つの基本的なビューがあります。アニメーションを違った局面から見ることができます:

ドープシート(DopeSheet)(eng)
ドープシートでは複数のアクションを一度に編集できます。
アクションエディタ(Action Editor)(eng)
アクションエディタ はデフォルトの、もっとも便利なモードです。アクションの定義や調節はここで行えます。
シェイプキーエディタ(Shape Key Editor)(eng)
シェイプキーエディタ は シェイプ(Shape) Ipo データブロック専用です。直前のモードと同じアクションデータブロックを使用・編集します。ただ、アクションエディタ モードが シェイプ チャネルをとてもうまく扱え、それ以上の要素もないので、いまでは役に立たなくなっているようです。
グリースペンシル(Grease Pencil)(eng)
グリースペンシル は グリースペンシルツール のキーフレーム専用です。グリースペンシルレイヤーごとにストリップがあり、これでキーをつかむことができるので、スケッチのアニメーションタイミングを簡単に割り当て直せます。このモードは、グリースペンシルのデータを閲覧し、編集する別の方法にすぎないので、データブロックを使用しません(このためアクションとは無関係です)。スケッチしたウィンドウの数だけ(3Dビュー、UV/画像エディタ等)、上層のグリースペンシルチャネルができることに注意してください。


Interface

(インターフェイス)

アクションエディタ(Action Editor) のインターフェイスはどこか FCurve エディタ のものに似ており、3つの領域に分かれています:

Object と Shape チャネルを持つアクションエディタモードのアクションエディタウィンドウ


ヘッダーバー
メニュー、エディタのモードに関連するコントロール群、アクションデータブロックに関連するコントロール群、それに2、3の他のツール(コピー・ペーストボタンやスナップの種類など)があります。
メイン領域
この中には、すべての可視のアクションチャネルのキーフレームがあります。
他の「時系列」ウィンドウと同様、X軸が時間を表します。Y軸は FCurve エディタと違ってそれ自身に意味を持たず、単にアクションチャネルが積み重なった状態です。それぞれが水平方向に伸びる色のついたストリップとして表示されます(動いている/キーを打たれた区間は濃い色になります)。
チャネルストリップ上にキーフレームが置かれ、薄い灰色(非選択状態)か黄色(選択状態)のダイアモンドで表現されます。
このウィンドウの重要な機能のひとつは、どのチャネル(例えば Ipo曲線)が「実際に」影響を受けるのか、ただちに見られることです。二つの隣り合うキーフレーム間で指定チャネルの値がまったく変化しない場合、この間には、灰色(非選択)か黄色(選択)の線が引かれます。
左の「リストツリー」
この部分はアクションチャネルの「ヘッダー」およびその階層構造を表しています。基本的に、次の項目を含みます:
  • 「上層」のチャネル。FCurve データブロック全体を表しています(したがって Object 用のもの、Shape 用のもの…等があります)。元になる FCurve データブロックで定義された、すべてのキーフレームの集合です。
  • 「中層」のチャネル。現在は使われていないようです(上層チャネルごとに存在しており、すべて FCurves という名前で、オプションはひとつもありません)。
  • 「下層」のチャネル。個々の FCurveと、そのキーフレームを表します(幸いにも、キーを打たれた Ipo だけが表示されます)。
各層は親のチャネルの左にある小さな矢印で、広げたり折り畳んだりできます。
チャネルのヘッダーの右には、チャネルの設定用コントロールがあります:
  • 小さな「スピーカー」をクリックすると、そのチャネルをミュートできます(子チャネルがあれば、それもすべてミュートされます)。
  • 小さな「南京錠」をクリックすると、このチャネルと子チャネルを編集できないようにします(NLA内でも動作しますが、元になるFCurveの編集はできることに注意してください)。
チャネルは選択状態(文字が白く、ストリップが灰-青色)か非選択状態(文字が黒く、ストリップがピンク-茶色)にできます。切り替えには LMB Template-LMB.png クリックを使ってください。
ヘッダーを CtrlLMB Template-LMB.png すると、チャネルのプロパティにアクセスできます。
最後に、この他に、現在のキーフレームの値を変更したり、新規に追加したりできる、値のスライダーを持つ列があります。低層のチャネル(例:個々のFCurve)に対してのみ利用できます。スライダーの表示のさせ方は 後述 します。


View Menu

(ビューメニュー)

スライダーを表示させたアクションエディタ
リアルタイム更新(Realtime Updates)
キーフレームをトランスフォームしたときに、アニメーションへの変更が他のビューに反映されます
フレーム数インジケータを表示(Show Frame Number Indicator)
現在のフレームを表す線の近くに、フレーム番号を表示します
スライダーを表示(Show Sliders)
チャネルに値のスライダーを表示させるかどうかの切り替えです(図「Object と Shape チャネルを持つアクションエディタモードのアクションエディタウィンドウ」をご覧ください)。
グループ色を使う(Use Group Colors)
グループとチャネルを、対応するグループとマッチする色で描画します。
AutoMerge Keyframes
近接するキーフレームを自動的に結合します
Sync Markers
マーカーをキーフレームの編集に同期します
Show Seconds
X軸に時間をフレームと秒のどちらで表示するか選びます。
Set Preview RangeP
再生に使われるフレーム範囲をインタラクティブに決めます。AltA のリアルタイム再生で使われる、一時的なプレビュー範囲を決めることができます(これは Timeline ウィンドウヘッダー の Pr オプションと同じものです)。
Clear Preview RangeAltP
プレビュー範囲を消去します。
Auto-Set Preview Range
アクション全体が再生されるように、プレビュー範囲を自動的に設定します。

Select Menu

(選択メニュー) F-カーブ をご覧ください。

Marker Menu

(マーカーメニュー) マーカー をご覧ください。